Como instalar VMware server en Ubuntu Intrepid (8.10)

1- Primeramente,obtener la licencia VMware desde aqui

2- Instalar los paquetes siguientes
apt-get install linux-source-2.6.27 linux-libc-dev xinetd

3- Despues,descargar VMware
wget http://download3.vmware.com/software/vmserver/VMware-server-1.0.8-126538.tar.gz
Untar
tar -xvzf VMware-server-1.0.8-126538.tar.gz
cd vmware-server-distrib/

4- Correr el instalador
./vmware-install.pl
-> Responder yes a cada pregunta hasta que llegue (run the configured script),a la cual responderemos no

5- Ahora,es necesario descargar el parche con el fin de construir el módulo del kernel (Probado con 2.6.27-7-generic)
wget http://www.insecure.ws/warehouse/vmware-update-2.6.27-5.5.7-2.tar.gz
tar -xvzf vmware-update-2.6.27-5.5.7-2.tar.gz
cd vmware-update-2.6.27-5.5.7-2
./runme.pl
-> Respondemos yes a todas las preguntas,ejecutamos el script de configuración y pulsamos ENTER para utilizar la configuración predeterminada.

-> Agregar la licencia.
-> A buscarse la vida con los iconos.

6- Verificar si el servicio està corriendo
/etc/init.d/vmware status
Bridged networking on /dev/vmnet0 is running
Host-only networking on /dev/vmnet1 is running
Host-only networking on /dev/vmnet8 is running
NAT networking on /dev/vmnet8 is running
Module vmmon loaded
Module vmnet loaded

Listo! o no?

About these ads

20 responses

  1. Gracias man, estaba en la misma situación que el comentario anterior, 5 tutos y nada hasta que encontre este… Rules…

    Viva Linux…

  2. Estuve siguiendo los pasos de tu conf y me di cuenta de que previamente se necesita instalar con sudo aptitude install g++, para que pueda compilar bien el vmware

  3. Hola, estoy intentando instalar el vmware player en ubuntu 8.10, pero dureante la instalación me pide el kernel 2.6.27.7-generic, y solo tengo el 2.6.27.11-generic, con el consiguiente error…. que puedo hacer?

  4. aquí se muere la instalación

    What is the location of the directory of C header files that match your running
    kernel? [/lib/modules/2.6.27-11-generic/build/include]

    Extracting the sources of the vmmon module.

    Building the vmmon module.

    Using 2.6.x kernel build system.
    make: se ingresa al directorio `/tmp/vmware-config1/vmmon-only’
    make -C /lib/modules/2.6.27-11-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: se ingresa al directorio `/usr/src/linux-headers-2.6.27-11-generic’
    CC [M] /tmp/vmware-config1/vmmon-only/linux/driver.o
    En el archivo incluído de /tmp/vmware-config1/vmmon-only/./include/machine.h:24,
    from /tmp/vmware-config1/vmmon-only/linux/driver.h:15,
    from /tmp/vmware-config1/vmmon-only/linux/driver.c:49:
    /tmp/vmware-config1/vmmon-only/./include/x86.h:830:1: aviso: se redefinió “PTE_PFN_MASK”
    En el archivo incluído de include/asm/paravirt.h:7,
    from include/asm/irqflags.h:55,
    from include/linux/irqflags.h:57,
    from include/asm/system.h:11,
    from include/asm/processor.h:17,
    from include/linux/prefetch.h:14,
    from include/linux/list.h:6,
    from include/linux/module.h:9,
    from /tmp/vmware-config1/vmmon-only/linux/driver.c:12:
    include/asm/page.h:22:1: aviso: esta es la ubicación de la definición previa
    En el archivo incluído de /tmp/vmware-config1/vmmon-only/linux/vmhost.h:13,
    from /tmp/vmware-config1/vmmon-only/linux/driver.c:71:
    /tmp/vmware-config1/vmmon-only/./include/compat_semaphore.h:5:27: error: asm/semaphore.h: No existe el fichero ó directorio
    /tmp/vmware-config1/vmmon-only/linux/driver.c:146: error: se especificó el campo desconocido ‘nopage’ en el inicializador
    /tmp/vmware-config1/vmmon-only/linux/driver.c:147: aviso: inicialización desde un tipo de puntero incompatible
    /tmp/vmware-config1/vmmon-only/linux/driver.c:150: error: se especificó el campo desconocido ‘nopage’ en el inicializador
    /tmp/vmware-config1/vmmon-only/linux/driver.c:151: aviso: inicialización desde un tipo de puntero incompatible
    /tmp/vmware-config1/vmmon-only/linux/driver.c: En la función ‘LinuxDriver_Ioctl’:
    /tmp/vmware-config1/vmmon-only/linux/driver.c:1670: error: demasiados argumentos para la función ‘smp_call_function’
    make[2]: *** [/tmp/vmware-config1/vmmon-only/linux/driver.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config1/vmmon-only] Error 2
    make[1]: se sale del directorio `/usr/src/linux-headers-2.6.27-11-generic’
    make: *** [vmmon.ko] Error 2
    make: se sale del directorio `/tmp/vmware-config1/vmmon-only’
    Unable to build the vmmon module.

    For more information on how to troubleshoot module-related problems, please
    visit our Web site at “http://www.vmware.com/download/modules/modules.html” and
    “http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html”.

    Execution aborted.

  5. Bueno,ayer despues de hacer un fresh install,se me instalò sin problema,no se si serà la version de make que usè anteriormente o alguna configuracion mal,tambien me dio problemas con Execution aborted pero ya no,raro esto no?.Saludos Nico.

  6. Qero | prueba -> sudo apt-get install g++ build-essential headers files faltantes?,prueba -> sudo aptitude -y install xinetd build-essential linux-headers-`uname -r` ia32-libs libc6-i386
    ————————-
    Saludos

  7. Mejor dicho Nico: cambiamos a sudo aptitude install build-essential linux-kernel-headers xinetd en el paso 2.

  8. disculpa la pregunta si es muy tonta pero yo tengo en mi pc el windows xp y mi disco esta partido en 2, entonces podre instalar el vmware sin problemas o debo hacer algo previo?…soy novato porfavor indicarme lo k debo hacer antes de esto y si es k rekiero de una dualcore, porque mi pc es pentium 4

    gracias

    • Windows y Ubuntu 8.10 en tu maquina,asumo que ès a eso a lo que te refieres.vmware se instala en tu particiòn Linux,en este caso.No creo que tengas ningùn problema.

  9. Hola a todos, me da el mismo error de Qero, e probado el comando que le dijiste pero me dice lo siguiente :

    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    g++ ya está en su versión más reciente.
    fijado g++ como instalado manualmente.
    build-essential ya está en su versión más reciente.
    0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
    root@enzo-laptop:/home/enzo/Escritorio/vmware-server-distrib# aptitude -y install xinetd build-essential linux-headers-`uname -r` ia32-libs libc6-i386
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    Leyendo la información de estado extendido
    Inicializando el estado de los paquetes… Hecho
    No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con “ia32-libs”
    No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con “libc6-i386″
    No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con “ia32-libs”
    No se pudo encontrar ningún paquete cuyo nombre o descripción coincida con “libc6-i386″
    No se instalará, actualizará o eliminará ningún paquete.
    0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
    Necesito descargar 0B de ficheros. Después de desempaquetar se usarán 0B.
    Escribiendo información de estado extendido… Hecho
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    Leyendo la información de estado extendido
    Inicializando el estado de los paquetes… Hecho

    Alguien puede echarme un cable?

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s