Posible soluciòn a problemas instalando Firefox-3.5.tar.bz2 en Ubuntu 9.04

Si te ha sido dificil instalar Firefox 3.5 (tar.bz2) en Jaunty,Quizas algunas de estas opciones de instalaciòn te ayuden a lograr tu objetivo (Instalar y correr FF 3.5).

Siguiendo los pasos a continuaciòn no perderás ningún marcador ni la configuración actual de tu navegador. Pero siempre es recomendable crear una copia de seguridad.

Instalaciòn

  1. Descarga Firefox 3.5 desde Firefox.com en tu escritorio (desktop)
  2. Click derecho en el firefox-3.5.tar.bz2 para extraerlo
  3. Ahora tendràs una carpeta en tu escritorio llamada Firefox ,renombrala a Firefox-3.5
  4. En un terminal -> sudo nautilus
  5. Navegar a -> File System -> usr -> lib ( /usr/lib/ ) y copiar la carpeta Firefox-3.5 a ese directorio.
  6. Abrir la carpeta Firefox-3.5 y buscar el archivo llamado Firefox.
  7. Click derecho y Make Link ,Crearà un archivo llamado Link to Firefox.
  8. Ya existe un enlace llamado Firefox ,renombrarlo a Firefox.old (si no existe, no te preocupes), renombrarlo solo a Firefox.

Listo!.Reiniciar Firefox!.

[Source]

End.

Update (No .tar.bz2): Quizas la mejor manera de instalar FF 3.5,sea via los repos (ubuntu-mozilla-daily repository).

Instalaciòn:

Agregar la linea siguiente a /etc/apt/sources.list:

deb http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu jaunty main

Obtener la llave:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 247510BE

Refrescar system cache:

sudo apt-get update

Se necesitan los paquetes: latex-xft-fonts y firefox-3.5-gnome-support:

sudo apt-get install firefox-3.5 firefox-3.5-gnome-support latex-xft-fonts

En este momento, hay 2 versiones diferentes de Firefox que coexisten en el sistema, 3.0.11 y 3.5.1. Al ejecutar “firefox” desde la línea de comandos o al seleccionarla desde el menú de Aplicaciones, la versión 3.0.11 se dispararà. Podría ser conveniente lanzar la nueva versión por defecto:

$ sudo su
$ cd /usr/bin
$ ll firefox*
lrwxrwxrwx 1 root root 11 2009-06-22 16:45 firefox -> firefox-3.0
lrwxrwxrwx 1 root root 32 2009-06-22 16:45 firefox-3.0 -> ../lib/firefox-3.0.11/firefox.sh
lrwxrwxrwx 1 root root 34 2009-07-01 21:17 firefox-3.5 -> ../lib/firefox-3.5.1pre/firefox.sh
$ rm firefox
$ ln -s firefox-3.5 firefox

Nota: La nueva versión instalada es “Shiretoko”. Ese es el nombre utilizado para identificar 3.5 durante su desarrollo.

[Source]

End

Extra:

cp -r ~/.mozilla/firefox/ ~/firefox_backup

wget -O - ttp://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.5/linux-i686/en-US/firefox-3.5.tar.bz2 | tar xj -C ~

~/firefox/firefox

17 thoughts on “Posible soluciòn a problemas instalando Firefox-3.5.tar.bz2 en Ubuntu 9.04

  1. Ernesto 03/07/2009 / 12:38

    La primera me ha funcionado perfectamente,solo te faltò poner como borrar la version antigua.Gracias.

    Saludos

    Like

    • Nico 03/07/2009 / 12:41

      Correcto!.Solo eliminar la carpeta 3.0.11.Slds.

      Like

  2. pepe 03/07/2009 / 17:57

    no es por nada, pero cuando firefox 3.5 en REPOSITORIOS de ubuntu?

    Like

  3. caos30 03/07/2009 / 20:18

    Nico, no me ha funcionado el comando:

    ll firefox*

    y he utilizado este otro que me da la misma información:

    ls -l firefox*

    Gracias por el tutorial!!!
    SERGI

    Like

  4. caos30 03/07/2009 / 20:29

    Ya está: acabo de reiniciar con el nuevo FF3.5

    Me sorprenden varias cosas:

    – en lugar de la palabra Mozilla o FireFox, en todas partes pone “Shiretoko” (por ejemplo, “About Shiretoko”… extraño, no? pensé que solo era el nombre a usar entre desarrolladores. Será un bug?

    – diría que las fuentes no se renderizan igual! en este recuadro por ejemplo del formulario de añadir comentario, la grafía es mucho más delgada que antes :S

    – aunque no tengo problema con el inglés (y menos a nivel técnico/informático) ya me había acostumbrado a tener los menús de FF en castellano. Ahora los tengo de nuevo en inglés ¿? Alguien sabe cómo puedo cambiarlo? he mirado en “editar preferencias” pero no encuentro la opción (ahora que lo pienso… no debería estar esto en la primera pestaña de todas?😉 se aceptan sugerencias…. (el resto del sistema -Ubuntu 8.10- lo tengo en castellano.

    Gracias de antemano,
    SERGI

    Like

  5. caos30 03/07/2009 / 20:42

    Más…

    – la buena noticia es que me ha “recuperado” los addons (delicious, web developer, urlink, etc..) y plugins (un alivio que no “perdiera” el de Flash! jejeje) y configuración del FF anterior!😉

    – la “mala” noticia -por lo que he leido ahora en otros blogs- es que esta parece no ser una “versión final”?… por eso lo del inglés y por eso lo de “Shiretoko”…

    – también dicen por ahí que para Ubuntu 9.04 ya está FF3.5 en los repositorios. ¿Será? (lástima que yo aún use 8.10😉 )

    – esta parece ser la página oficial de Ubuntu-FireFox:

    https://help.ubuntu.com/community/FirefoxNewVersion

    (en inglés😉 )

    Like

  6. caos30 03/07/2009 / 20:56

    Upssss…. Nico, la que nos has liado!!! y todo por las prisas buen hombre!!! jajaja…

    He leido el enlace anterior oficial, en donde dicen lo siguiente respecto el repositorio “ubuntu-mozilla-daily” (traducido):

    ________________________________________

    Los usuarios de Hardy, Intrepid, Jaunty y Karmic pueden obtener la última versión de desarrollo de Firefox del repositorio semi-oficial ubuntu-mozilla-daily. Este repositorio ofrece actualizaciones de Firefox que actualmente están bajo desarrollo – por ejemplo, en el momento de escribir esto, ya había una temprana versión alfa de Firefox 3.5.1. Aunque estos paquetes funcionarán correctamente la mayor parte del tiempo, puedes esperar que a veces se den cuelgues (“crashes”) u otros problemas.
    ________________________________________

    Es cierto que si miro en “about Shiretoko” en el menú de mi navegador aparece la versión “3.5.1pre” !!! Así que si no he entendido mal, ahora soy uno de los usuarios de la “versión de desarrollo” de FireFox ! uauuuu… en cierta manera siempre había querido serlo, pero por otra parte me “asusta” la posible inestabilidad del sistema.

    Bueno, la verdad sea dicha, después de la cantidad de addons que le he ido instalando a Firefox ya no me da tanta confianza de “privacidad” como al principio, así que vengo desde un tiempo atrás ya utilizando un navegador alternativo (en mi caso me funciona muy bien “Seamonkey” creo que también de Mozilla) para por ejemplo entrar en las webs de gestión de mis cuentas bancarias😉

    En fin, creo que durante un tiempo probaré esto de usar una versión en desarrollo🙂

    Gracias Nico😉
    SERGI

    Like

      • Nico 04/07/2009 / 10:53

        Ok,la cosa es mas o menos asì:

        La version que està en los repos es un paquete especial que todavia contiene una old beta release,pero serà actualizado pronto.FF 3.5 no serà introducida en Ubuntu hasta que no salga el 9.10.

        Por el momento,lo mas seguro es:

        cp -r ~/.mozilla/firefox/ ~/firefox_profile_backup
        deb http://ppa.launchpad.net/ubuntu-mozilla-security/ppa/ubuntu jaunty main

        eliminar el repo despues de la instalaciòn (firefox-3.5) sino quieres actualizaciones.

        Applications->Internet->Shiretoko Web Browser.

        Like

  7. caos30 04/07/2009 / 03:19

    mmmm… nen… con la instalación de FF3.5.1pre se me ha “ido”… Prism😦

    He reinstalado Prism, pero sigue sin ir. Creo que Prism depende de Firefox para funcionar, ¿verdad?…

    Se aceptan sugerencias. Pues la verdad no sé qué hacer, y Prism lo utilizo a diario para ejecutar una aplicación web que me he hecho y me va de perlas😉

    SERGI

    Like

    • Nico 04/07/2009 / 10:06

      Creo que la versionitis ha confundido a muchos (me incluyo) pero en caso de que te arrepientas:

      sudo apt-get remove firefox-3.5

      Elimina los repos y :

      sudo apt-get update && sudo apt-get install firefox

      Slds.

      Like

  8. caos30 04/07/2009 / 03:33

    Buscando por ahí he visto que Prism se puede instalar (en su versión 1.0b) como addon😀 así que me he ido directo a la página de addons de Mozilla para Firefox:

    https://addons.mozilla.org/es-ES/firefox/addon/6665

    Más mi pena ha venido al intentar instalarlo: después de descargarlo e intentar instalarlo me ha dicho que no es compatible con Firefox 3.5.1pre.

    Pues en fin… a esperarse… no creo que tarden mucho en hacerlo compatible😉

    Por cierto, para el que no lo conozca (y con el permiso implícito de Nico) Prism es un fantástico complemento para el navegador Firefox proque permite crearte una especie de “acceso directo” en tu escritorio para abrir en una “ventana simplificada del navegador” (opcionalmente sin botones, ni menús ni barras) la aplicación web que tú prefieras. De esa forma: 1) dispones en tu escritorio de una acceso casi inmediato a tus aplicaciones web más usadas, 2) éstas se ejecutan en una ventana completamente “desnuda”, en donde el protagonismo es enteramente de la propia interfaz de la web😉

    Un saludo!
    SERGI

    Like

    • Nico 04/07/2009 / 10:57

      Creo haber hablado sobre Prism hace un tiempo ya.Es verdaderamente interesante.Slds.

      Like

  9. pepe 08/08/2009 / 00:54

    hola si instalo el firefox3.5 desde repo se instala en ingles, hay forma de cambiarlo? plis

    Like

    • Nico 08/08/2009 / 14:50

      No encuentro ninguna traducción al Español registrada la base de datos.Le voy a dar una ojeada al tema.

      Update:
      Ok,reemplaza US por ES para descargar la version en Español.Mira a ver si te va bien.Slds.

      Like

  10. kuku 09/07/2011 / 14:55

    Por que no han puesto un ejecutable tipo .deb. Si buscan en google como instalar un tar.bz2 aver si encuentran alguna explicación convincente. Desde luego que ganas de liarla. No es más seguro por consola porque lo que hace la gente es copiar y pegar lo que ve en los foros en la consola y al final instalan cosas sin saber como se han instalado ni en que carpeta han quedado. En fin, al que le gusta cacharrear bienvenido pero a las personas normales que quieren instalar un programa que necesitan y le meten tantas vueltas los vuelven locos.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s