Ubuntu 10.04 en Getaway Notebook | Tarjetas Broadcom con B43 y bcm43xx Firmware,etc..

Hace un par de dias un amigo me pidió de favor que le hiciera una instalacion y configuracion de Ubuntu 10.04 en su Getaway MX6025 Notebook y le dije: No prob dude!.

Resulta que Linux no funciona correctamente en todas las maquinas y la cosa no es instalar sino el show de comandos que tenemos que lanzar para configurar el sistema como queremos en algunas ocaciones despues de instalada la distro y algunas veces hay que empezar a lanzar comandos antes de botear por ejemplo:

En este equipo especificamente (para no caer en detalles) lleva consigo el bug i8xxFreezes y tenemos que botear añadiendo i915.modeset=1 despues de quiet splash sin () y despues de instalada la distro lo haremos permanente utilizando el siguiente comando:

echo options i915 modeset=1 | sudo tee /etc/modprobe.d/i915-kms.conf && sudo update-initramfs -u

Otra cosa que me chocó un poco fue el problema que saltó con los drivers de wireless chipsets (No Conexion) – b43-fwcutter que ya estaba instalado pero no pude extraeer el firmware /lib/firmware y nada, me salío mas facil probar (sin conexion) via otra maquina y descargar un par de paquetes .deb (b43 firmware y bcm43xx firmware) meterlos en un usb, instalarlos (ambos por si acaso), reiniciar y listo! el wireless empezó a trabajar sin problema alguno.

Soy alergico a tener que explicar detalle por detalle pero alguno que otro me agradecerán este corto howto.

14 thoughts on “Ubuntu 10.04 en Getaway Notebook | Tarjetas Broadcom con B43 y bcm43xx Firmware,etc..

  1. Gen X 11/08/2010 / 17:24

    es preferible la brevedad consistente, no la extenuacion bofa. por ejemplo hay tutoriales nefastos que hablan y hablan cuando podrian reducir 40 minutos o 1 hora a solo 10 minutos de material concentrado y explosivo ;D

    Like

  2. Kvothe 12/08/2010 / 02:06

    Muy buen howto y si es muy molesto cuando no todo queda a la primera, aunque claro, para todo siempre hay solución, me sucedió algo parecido al instalar ubuntu 10.04 en mi notebook vaio vpc ee23el, al finalizar la instalación no detecta el touchpad, todo se solucionó agregando una linea al GRUB y actualizando y listo.

    Otra cosa que me sucedió en dicha notebook, es que ubuntu no da sonido, ni aunque le supliques, he provado cuanto tutorial he visto en la red, y nada, hasta el día de hoy sigo en busca de una solución.

    PD: muy buen blog, llevo tiempo siguiendolo.

    Like

    • NullCool 23/08/2010 / 21:18

      Kvothe tengo el mismo pc >_< porfavooor dime que linea le añadiste..use mil tutoriales y nada😦 snif sniff hahaha es que es una joda andar con el mouse usb ¬¬
      nullcool@gmail.com

      Like

  3. Julio Sanchez Berro 12/08/2010 / 11:39

    Muchisimas gracias, llevo 2 dias (y sus noches, intentando configurar la tarjeta inalambrica de mi portatil… he probado de por todos lados….visitados decenas de paginas de internet, (español e ingles) y gracias a ti la he podido configurarla……

    Muchas gracias..

    Julio Sanchez

    Like

    • Nico 12/08/2010 / 14:02

      Julio, me alegra que te haya sido util el howto, ya lo dije que a alguien le serviriá. Slds.

      Like

  4. SERGI 12/08/2010 / 16:56

    Hola Nico, casualmente ayer instalé un Ubuntu 10.04 en el PC de escritorio de mi cuñado con una tarjeta Wireless PCI precisamente la BCM4310 (si no recuerdo mal…. aunque estoy seguro que era BCM43xx).

    De hecho, el problema lo tuve realmente en la partición Windows (la que usa para los juegos) en la que NO HUBO MANERA DE INSTALARLE los drivers… fue desesperante!!!? probé como mínimo 5 descargas diferentes y nada…

    En cambio, en Ubuntu 10.04, no hubo que hacer NADA. La tarjeta se reconoció de inmediato y funcionó perfectamente desde el principio. No entiendo cómo podéis haber tenido problema con eso… Si no supiera que eres un informático experimentado (y un linuxero profesional, jejeje) te preguntaría si no estaría mal “bajada” la distro o mal quemada. Pero en fin, me imagino que no.

    Saludos!
    SERGI
    ** SÒC CATALÀ i PARLO CATALÀ **

    Like

    • Nico 13/08/2010 / 09:05

      Sergi, my friend: Esto no es una ciencia exacta jajajaja y Linux es muy caprichoso con algunas maquinas. Y ya que hablas sobre eso,puedes buscar por la red y notarás que algunos usuarios han tenido el mismo problema pero con distintos modelos,inclusive con los drivers de w2 para getaway.

      No digo que sean malas maquinas,he trabajado con varias y algunos modelos van de maravilla pero como bien dije algunos modelos son malcriados y depende tambien mucho la edad.

      amigo mio, puedo haber quemado mal un cd de ubuntu a estas alturas pero no fue ese el caso, ya que lo mencionas, (lo comprobé).

      Slds y una vez mas, gracias por tus replays.

      Like

  5. SERGI 12/08/2010 / 16:59

    Por cierto, no sé si tendrá algo que ver, pero en una de mis laptops tengo un problema que no he sabido resolver (tampoco lo he mirado mucho, jijiji). Resulta que si arranco la laptop sin tenerla conectada a la corriente, es decir, solamente funcionando con la batería… pues entonces no me reconoce la tarjeta Wifi o no funciona… no sé lo que pasa la verdad. No es mayor problema, porque desde entonces arranco siempre con la laptop conectada a la red eléctrica. Pero me quedaría más tranquilo si pudiera resolverlo.

    Cualquier comentario que aporte luz me ayudaría😉
    Saludos de nuevo!
    SERGI

    Like

  6. Julio Sanchez Berro 12/08/2010 / 19:41

    Nico:

    Abri una entrada en un foro de programacion en linux (Gambas2),

    Alli explique todas las “vueltas” y pruebas que realice para llegar hasta tu solución

    http://www.gambas-es.org/viewtopic.php?f=8&t=865i

    Si no te importa, incluire en una entrada de mi blog sobre “mi experiencia sufrida” con la tarjeta de red y ubuntu 10.04 y tu solucion (como dices tu “corto howto.”).

    Gracias por tu aportación.

    Un saludo

    Julio

    Like

    • Nico 13/08/2010 / 09:11

      Julio: Claro que no importa! Slds.

      Like

  7. Rushmata 23/09/2012 / 08:19

    Genial, me funcionó a la perfección, estaba ya un poco frustrado de mirar en foros sin encontrar la solución; pero con instalar los 2 paquetes esos me fue Canela. Muchas Graciaaassss!!!

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s